Humidistat (C128WHD) turns Ultra Aire on but not off
Therma-Stor LLC
Therma-Stor Forum
ThermaStor.com Home PageTherm-Stor Forum Main Page
Therma-Stor Forum
 Home          Members     Calendar     Who's On

Welcome Guest ( Login | Register )
        



Humidistat (C128WHD) turns Ultra Aire on but... Expand / Collapse
Message
Posted 12/10/2017 1:25:10 PM Post #1799
 

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie
I have a newly installed Ultra Aire 155xt which replaced an older DVA 400 unit.

The replacement went well. The Humidstat I used before and also with the UA is a C128WDH. The UA unit turns on but will not turn off... unless I switch the circuit breaker.

Does anyone have any ideas of what might cause this. I have 2 of the C128WDH humidistats and both of them show the same behavior... so I find it hard to believe it is a problem with the Humidistats.

An image of the Humidity control unit is "attached" and also at [url=https://photos.google.com/photo/AF1QipMfYfDCLgrX1wiz8x_Oa3K4RGUavjs6pogGKyel][/url]

Any help is appreciated.

Posted 12/10/2017 1:27:49 PM Post #1800
 

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie
Here is the image (attached) I tried to include.

  Post Attachments 
IMG_3415.jpg (1 view, 362.38 KB)
« Prev Topic | Next Topic »


Reading This Topic Expand / Collapse
Active Users: 254 (254 guests, 0 members, 0 anonymous members)
No members currently viewing this topic.

Permissions Expand / Collapse

All times are GMT -6:00, Time now is 4:33pm

Therma-Stor Forum Home Page  |  ThermaStor.com Home Page

Copyright © 2019 Therma-Stor LLC